Проверьте что возвращает запрос:

$res_num = mysqli_query ($connect, "SELECT COUNT(id) FROM comment WHERE post='$id'");

Для подсчета записей в таблице используйте отдельный запрос с функцией COUNT(*).
https://dev.mysql.com/doc/refman/5.7/en … -rows.html

3

(3 ответов, оставленных в Работа с phpMyAdmin)

В логах можно посмотреть, что причина не в сервере. Если сервер принимает запрос и возвращает данные, то посмотрите в отладчике браузера на каком этапе происходит зависание. Возможно так срабатывает антивирус или блокировщик рекламы.

4

(3 ответов, оставленных в Работа с phpMyAdmin)

Смотрите журналы ошибок веб-сервера и MySQL. Поищите зацепку в логах.

5

(1 ответов, оставленных в Настройка phpMyAdmin)

Попробуйте убрать из запроса CHARACTER SET utf8 COLLATE utf8_bin.

Попробуйте очистить кеш браузера и проверьте конфигурационный файл phpMyAdmin, config.inc.php , он должен быть сохранен без БОМ байта, что можно проверить в Notepad++.

7

(1 ответов, оставленных в Установка phpMyAdmin)

У вас не запущен MySQL. Обратитесь на форум Денвера, если работаете на нем.

Eva пишет:

Появилась такая ошибка "Error at the line 249: DROP TABLE IF EXISTS `catalog_category_entity`;

Появилась после чего?

Попробуйте выполнить следующий запрос, или прописать его в дамп.

SET foreign_key_checks=0;

Так же может помочь вывод ошибки в разделе LATEST FOREIGN KEY ERROR:

SHOW ENGINE INNODB STATUS;

Если не поможет, то смотрите на типы данных связанных таблиц, типы должны быть идентичны.

10

(4 ответов, оставленных в Работа с phpMyAdmin)

Смотрите установку режима SQL запросов.
https://dev.mysql.com/doc/refman/5.7/en … alid_dates

11

(4 ответов, оставленных в Работа с phpMyAdmin)

Для данных типа DATETIME диапазон от '1000-01-01 00:00:00' до '9999-12-31 23:59:59'.
Нули подставляются при некорректном значении и их нельзя ставить по умолчанию.

12

(16 ответов, оставленных в Настройка phpMyAdmin)

В конфигурационном файле php.ini надо подключить расширение mbstring.
Поищите и раскомментируйте строку:
extension=php_mbstring.dll

13

(16 ответов, оставленных в Настройка phpMyAdmin)

php.ini не найден. Посмотрите его в указанных каталогах.

14

(16 ответов, оставленных в Настройка phpMyAdmin)

Вы копировали php.ini в E:\wamp64\bin\php\php7.1.9\phpForApache.ini
Веб сервер ищет конфигурационный файл здесь:
E:/wamp64/bin/apache/apache2.4.27/bin/php.ini or e:/wamp64/bin/php/php5.6.31/phpforapache.ini

Версии PHP разные. Где-то ошибка.

15

(16 ответов, оставленных в Настройка phpMyAdmin)

Проверьте пути и версии, они отличаются.
E:/wamp64/bin/apache/apache2.4.27/bin/php.ini or e:/wamp64/bin/php/php5.6.31/phpforapache.ini

16

(16 ответов, оставленных в Настройка phpMyAdmin)

Eva пишет:

mklink не распознано

Проверьте, чтобы командная строка запускалась из под администатора.

17

(16 ответов, оставленных в Настройка phpMyAdmin)

Скопируйте ошибку, пожалуйста.

18

(1 ответов, оставленных в MySQL & phpMyAdmin)

Большие дампы импортируйте из файла локально.
https://forum.php-myadmin.ru/viewtopic. … 680#p13680

19

(1 ответов, оставленных в Установка phpMyAdmin)

Проверьте кавычки в конфигурационных файлах. Возможно причина в них. Если не поможет, то попробуйте другую версию phpMyAdmin.

Посмотрите журнал ошибок веб-сервера, возможно там можно будет найти зацепку. Из приведенного причина не видна.

Такой функции при импорте нет и она не предполагается к реализации, насколько мне известно.

Как вариант, используйте текстовый редактор, вроде vim, который позволяет редактировать файлы больших размеров.

22

(11 ответов, оставленных в MySQL & phpMyAdmin)

Пробуйте только это удалить:

/*!50017 DEFINER=`igoris9k_env`@`localhost`*/

23

(11 ответов, оставленных в MySQL & phpMyAdmin)

Пробуйте удалить строку в дампе, как я уже указал выше. Если после этого появится ошибка, то покажите ее.

24

(11 ответов, оставленных в MySQL & phpMyAdmin)

Попробуйте поискать в дампе строки такого вида и убрать их.

/*!50017 DEFINER=`another_user`@`1.2.3.4`*/

25

(11 ответов, оставленных в MySQL & phpMyAdmin)

Скрипту зачем-то нужен привелигированный пользователь. Лучше обратиться к пользователям этого скрипта, возможно проблема достаточно распространенная.